Can't update records because of missing record access in Salesforce CRM
This article helps you troubleshoot and resolve issues when users can't update CRM records in Sales app because of missing record access in Salesforce CRM.
Who is affected?
| Requirement type | Description |
|---|---|
| Client app | Sales app in Outlook |
| Platform | Web and desktop clients |
| OS | Windows and Mac |
| Deployment | User managed and admin managed |
| CRM | Salesforce |
| Users | Users trying to update a CRM record from Sales app |
Symptoms
When a user tries to update a CRM record from the Sales app in Outlook, the following error message is displayed:
To update Salesforce, ask for edit access for this record.
Cause
The user doesn't have edit access to the record in Salesforce.
When a user tries to edit a record, Sales app checks if the user has edit access to the object and record in Salesforce. If the user has edit access to the object but not to the record, the error message is displayed.
Resolution
A Salesforce administrator must provide edit access to the record in Salesforce by manually sharing the record with the user.
More information
If your issue is still unresolved, go to the Sales in Microsoft 365 Copilot - Microsoft Community Hub to engage with our experts.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
Third-party contact disclaimer
Microsoft provides third-party contact information to help you find additional information about this topic. This contact information may change without notice. Microsoft does not guarantee the accuracy of third-party contact information.
Source: Microsoft Learn Documentation | Originally published: 11/20/2025 | Author: shjais
